$re = '/([A-Z]{1,3}-[0-9]{4}.[0-9]{2}[A-Z]{1,3})/';
$str = 'http://www.withagen-attractieverhuur.nl/TipProduct/SP-2008.05A/Circus%20overdekt/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);