using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<div>)(.+?)(?:<\/div>)";
string input = @" <div>one</div>
<div>two</div>
<div>three</div>
<div>что-то</div>
<div>что-то
еще</div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}