re = /(?:<div>)(.+?)(?:<\/div>)/m
str = ' <div>one</div>
<div>two</div>
<div>three</div>
<div>что-то</div>
<div>что-то
еще</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end