import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<div>)(.+?)(?:<\\/div>)";
final String string = " <div>one</div>\n"
+ " <div>two</div>\n"
+ " <div>three</div>\n"
+ " <div>что-то</div>\n"
+ " <div>что-то\n"
+ " еще</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}