package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(?:<div>)(.+?)(?:<\/div>)`)
var str = ` <div>one</div>
<div>two</div>
<div>three</div>
<div>что-то</div>
<div>что-то
еще</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}