$re = '/(?:<div>)(.+?)(?:<\/div>)/ms';
$str = ' <div>one</div>
<div>two</div>
<div>three</div>
<div>что-то</div>
<div>что-то
еще</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);