#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)^%(deft|reff|refd) ([a-zA-Z_](?:\w|\.)*)(.*?)(?:(?:%\.)|(?:$^[^%]))"
Local $sString = "%deft sym.1 and this continues" & @CRLF & _
"% until we # get to %." & @CRLF & _
"%." & @CRLF & _
"%." & @CRLF & _
"This is not to be parsed" & @CRLF & _
"%refd sym.2 .%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")