using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^%(deft|reff|refd) ([a-zA-Z_](?:\w|\.)*)(.*?)(?:(?:%\.)|(?:$^[^%]))";
string input = @"%deft sym.1 and this continues
% until we # get to %.
%.
%.
This is not to be parsed
%refd sym.2 .%";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}