$re = '/^%(deft|reff|refd) ([a-zA-Z_](?:\w|\.)*)(.*?)(?:(?:%\.)|(?:$^[^%]))/sm';
$str = '%deft sym.1 and this continues
% until we # get to %.
%.
%.
This is not to be parsed
%refd sym.2 .%';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);