import Foundation
let pattern = #"^%(deft|reff|refd) ([a-zA-Z_](?:\w|\.)*)(.*?)(?:(?:%\.)|(?:$^[^%]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = ##"""
%deft sym.1 and this continues
% until we # get to %.
%.
%.
This is not to be parsed
%refd sym.2 .%
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}