package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)^%(deft|reff|refd) ([a-zA-Z_](?:\w|\.)*)(.*?)(?:(?:%\.)|(?:$^[^%]))`)
var str = `%deft sym.1 and this continues
% until we # get to %.
%.
%.
This is not to be parsed
%refd sym.2 .%`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}