import re
regex = re.compile(r"^%(deft|reff|refd) ([a-zA-Z_](?:\w|\.)*)(.*?)(?:(?:%\.)|(?:$^[^%]))", flags=re.DOTALL | re.MULTILINE)
test_str = ("%deft sym.1 and this continues\n"
"% until we # get to %.\n"
"%.\n"
"%.\n"
"This is not to be parsed\n"
"%refd sym.2 .%")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")