const regex = new RegExp('^%(deft|reff|refd) ([a-zA-Z_](?:\\w|\\.)*)(.*?)(?:(?:%\\.)|(?:$^[^%]))', 'sm')
const str = `%deft sym.1 and this continues
% until we # get to %.
%.
%.
This is not to be parsed
%refd sym.2 .%`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}