# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)(?:[@\/]|http|www)\S*|[^\n\p{L}]/ /gm;t' <<< "RT @digger: Чтото пиддес52 :|и так скучать( http://dot.com что,я +100500 surf cвихнусь так D:
Говорит: \"\"Кто то в углу сидит))) и погибает от голода!!! мы,хотя уже сидим изза\"\" :DD …
"