use strict;
my $str = 'RT @digger: Чтото пиддес52 :|и так скучать( http://dot.com что,я +100500 surf cвихнусь так D:
Говорит: ""Кто то в углу сидит))) и погибает от голода!!! мы,хотя уже сидим изза"" :DD …
';
my $regex = qr~(?<!\S)(?:[@/]|http|www)\S*|[^\n\p{L}]~mp;
my $subst = ' ';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";