using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?:[@/]|http|www)\S*|[^\n\p{L}]";
string substitution = @" ";
string input = @"RT @digger: Чтото пиддес52 :|и так скучать( http://dot.com что,я +100500 surf cвихнусь так D:
Говорит: ""Кто то в углу сидит))) и погибает от голода!!! мы,хотя уже сидим изза"" :DD …
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}