re = /(?<!\S)(?:[@\/]|http|www)\S*|[^\n\p{L}]/m
str = 'RT @digger: Чтото пиддес52 :|и так скучать( http://dot.com что,я +100500 surf cвихнусь так D:
Говорит: ""Кто то в углу сидит))) и погибает от голода!!! мы,хотя уже сидим изза"" :DD …
'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result