import Foundation
let pattern = #"(?<!\S)(?:[@/]|http|www)\S*|[^\n\p{L}]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
RT @digger: Чтото пиддес52 :|и так скучать( http://dot.com что,я +100500 surf cвихнусь так D:
Говорит: ""Кто то в углу сидит))) и погибает от голода!!! мы,хотя уже сидим изза"" :DD …
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)