import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?:[@/]|http|www)\\S*|[^\\n\\p{L}]";
final String string = "RT @digger: Чтото пиддес52 :|и так скучать( http://dot.com что,я +100500 surf cвихнусь так D:\n\n\n"
+ "Говорит: \"\"Кто то в углу сидит))) и погибает от голода!!! мы,хотя уже сидим изза\"\" :DD …\n";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}