import Foundation
let pattern = #"\\vv"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Test\\vv testing\\vv"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\replaced"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)