#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i) var reTitle = /\<a title\=\"(.*?)\"/g;" & @CRLF & _
""
Local $sString = "<a title="Add a Gmail account to Outlook - Outlook" href="https://support.office.com/en-us/article/add-a-gmail-account-to-outlook-70191667-9c52-4581-990e-e30318c2c081" class="ocSearchResultTitle ocEllipsis" data-urlsuffix="DevEx,5084.1" data-bi-area="results" ms.cmpgrp="Results" ms.pgarea="Body" ms.serplinkpos="1-1" data-bi-srchlinkpos="1-1" ms.searchpg="1" ms.searchquery="outlook%20Outlook%20"><img class="ocGPingImg" ms.cmpgrp="Results" ms.pgarea="Body">Add a Gmail account to <b><b>Outlook</b></b> - <b><b>Outlook</b></b></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")