# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r" var reTitle = /\<a title\=\"(.*?)\"/g;\n")
test_str = "<a title=\"Add a Gmail account to Outlook - Outlook\" href=\"https://support.office.com/en-us/article/add-a-gmail-account-to-outlook-70191667-9c52-4581-990e-e30318c2c081\" class=\"ocSearchResultTitle ocEllipsis\" data-urlsuffix=\"DevEx,5084.1\" data-bi-area=\"results\" ms.cmpgrp=\"Results\" ms.pgarea=\"Body\" ms.serplinkpos=\"1-1\" data-bi-srchlinkpos=\"1-1\" ms.searchpg=\"1\" ms.searchquery=\"outlook%20Outlook%20\"><img class=\"ocGPingImg\" ms.cmpgrp=\"Results\" ms.pgarea=\"Body\">Add a Gmail account to <b><b>Outlook</b></b> - <b><b>Outlook</b></b></a>"
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.