use strict;
my $str = '<a title="Add a Gmail account to Outlook - Outlook" href="https://support.office.com/en-us/article/add-a-gmail-account-to-outlook-70191667-9c52-4581-990e-e30318c2c081" class="ocSearchResultTitle ocEllipsis" data-urlsuffix="DevEx,5084.1" data-bi-area="results" ms.cmpgrp="Results" ms.pgarea="Body" ms.serplinkpos="1-1" data-bi-srchlinkpos="1-1" ms.searchpg="1" ms.searchquery="outlook%20Outlook%20"><img class="ocGPingImg" ms.cmpgrp="Results" ms.pgarea="Body">Add a Gmail account to <b><b>Outlook</b></b> - <b><b>Outlook</b></b></a>';
my $regex = qr/ var reTitle = /\<a title\=\"(.*?)\"/g;
/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}