const regex = / var reTitle = /\<a title\=\"(.*?)\"/g;
/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' var reTitle = \/\\<a title\\=\\"(.*?)\\"\/g;
', 'gi')
const str = `<a title="Add a Gmail account to Outlook - Outlook" href="https://support.office.com/en-us/article/add-a-gmail-account-to-outlook-70191667-9c52-4581-990e-e30318c2c081" class="ocSearchResultTitle ocEllipsis" data-urlsuffix="DevEx,5084.1" data-bi-area="results" ms.cmpgrp="Results" ms.pgarea="Body" ms.serplinkpos="1-1" data-bi-srchlinkpos="1-1" ms.searchpg="1" ms.searchquery="outlook%20Outlook%20"><img class="ocGPingImg" ms.cmpgrp="Results" ms.pgarea="Body">Add a Gmail account to <b><b>Outlook</b></b> - <b><b>Outlook</b></b></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}