// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i) var reTitle = /\<a title\=\"(.*?)\"/g;
"#).unwrap();
let string = "<a title=\"Add a Gmail account to Outlook - Outlook\" href=\"https://support.office.com/en-us/article/add-a-gmail-account-to-outlook-70191667-9c52-4581-990e-e30318c2c081\" class=\"ocSearchResultTitle ocEllipsis\" data-urlsuffix=\"DevEx,5084.1\" data-bi-area=\"results\" ms.cmpgrp=\"Results\" ms.pgarea=\"Body\" ms.serplinkpos=\"1-1\" data-bi-srchlinkpos=\"1-1\" ms.searchpg=\"1\" ms.searchquery=\"outlook%20Outlook%20\"><img class=\"ocGPingImg\" ms.cmpgrp=\"Results\" ms.pgarea=\"Body\">Add a Gmail account to <b><b>Outlook</b></b> - <b><b>Outlook</b></b></a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}