import Foundation
let pattern = #"""
var reTitle = /\<a title\=\"(.*?)\"/g;
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"<a title="Add a Gmail account to Outlook - Outlook" href="https://support.office.com/en-us/article/add-a-gmail-account-to-outlook-70191667-9c52-4581-990e-e30318c2c081" class="ocSearchResultTitle ocEllipsis" data-urlsuffix="DevEx,5084.1" data-bi-area="results" ms.cmpgrp="Results" ms.pgarea="Body" ms.serplinkpos="1-1" data-bi-srchlinkpos="1-1" ms.searchpg="1" ms.searchquery="outlook%20Outlook%20"><img class="ocGPingImg" ms.cmpgrp="Results" ms.pgarea="Body">Add a Gmail account to <b><b>Outlook</b></b> - <b><b>Outlook</b></b></a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)