#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[+]([0-9]{1,3})(([\s\-\.\(\)]*)([0-9]*)([\s\-\.\(\)]*)){1,3}"
Local $sString = "+94 (666) 999-5555" & @CRLF & _
"" & @CRLF & _
"+42 555.123.4567"
Local $sSubst = "+$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)