using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[+]([0-9]{1,3})(([\s\-\.\(\)]*)([0-9]*)([\s\-\.\(\)]*)){1,3}";
string substitution = @"+$1 $2";
string input = @"+94 (666) 999-5555
+42 555.123.4567";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}