const regex = /[+]([0-9]{1,3})(([\s\-\.\(\)]*)([0-9]*)([\s\-\.\(\)]*)){1,3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[+]([0-9]{1,3})(([\\s\\-\\.\\(\\)]*)([0-9]*)([\\s\\-\\.\\(\\)]*)){1,3}', 'g')
const str = `+94 (666) 999-5555
+42 555.123.4567`;
const subst = `+$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);