use strict;
my $str = '+94 (666) 999-5555
+42 555.123.4567';
my $regex = qr/[+]([0-9]{1,3})(([\s\-\.\(\)]*)([0-9]*)([\s\-\.\(\)]*)){1,3}/p;
my $subst = '+$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";