import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[+]([0-9]{1,3})(([\\s\\-\\.\\(\\)]*)([0-9]*)([\\s\\-\\.\\(\\)]*)){1,3}";
final String string = "+94 (666) 999-5555\n\n"
+ "+42 555.123.4567";
final String subst = "+$1 $2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}