import Foundation
let pattern = #"[+]([0-9]{1,3})(([\s\-\.\(\)]*)([0-9]*)([\s\-\.\(\)]*)){1,3}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
+94 (666) 999-5555
+42 555.123.4567
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"+$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)