$re = '/[+]([0-9]{1,3})(([\s\-\.\(\)]*)([0-9]*)([\s\-\.\(\)]*)){1,3}/';
$str = '+94 (666) 999-5555
+42 555.123.4567';
$subst = "+$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;