using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:\d+(?:\.\d+)|[a-z\s0-9]+)\b";
string substitution = @"";
string input = @"<Array>""1bbl"" 2bbl ""is as"" 0.22 ""3""</Array>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}