const regex = new RegExp('\\b(?:\\d+(?:\\.\\d+)|[a-z\\s0-9]+)\\b', 'gm')
const str = `<Array>"1bbl" 2bbl "is as" 0.22 "3"</Array>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);