# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(,)(?=(?:[^}]|{[^{]*})*$)/\n/g;t' <<< "\"asd\", domain={\"id\"=\"test\"}, names={\"index\"=\"user.all\", \"show\"=\"user.view\"}, test=\"test\""