$re = '/(,)(?=(?:[^}]|{[^{]*})*$)/';
$str = '"asd", domain={"id"="test"}, names={"index"="user.all", "show"="user.view"}, test="test"';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;