#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(,)(?=(?:[^}]|{[^{]*})*$)"
Local $sString = ""asd", domain={"id"="test"}, names={"index"="user.all", "show"="user.view"}, test="test""
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)