re = /(,)(?=(?:[^}]|{[^{]*})*$)/
str = '"asd", domain={"id"="test"}, names={"index"="user.all", "show"="user.view"}, test="test"'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result