import Foundation
let pattern = #"(,)(?=(?:[^}]|{[^{]*})*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""asd", domain={"id"="test"}, names={"index"="user.all", "show"="user.view"}, test="test""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)