using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(,)(?=(?:[^}]|{[^{]*})*$)";
string substitution = @"\n";
string input = @"""asd"", domain={""id""=""test""}, names={""index""=""user.all"", ""show""=""user.view""}, test=""test""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}