const regex = /(,)(?=(?:[^}]|{[^{]*})*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(,)(?=(?:[^}]|{[^{]*})*$)', 'g')
const str = `"asd", domain={"id"="test"}, names={"index"="user.all", "show"="user.view"}, test="test"`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);