#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*?<pre>.*\s?((<br\s*?\/?>\s?).*?){1,}<\/pre>"
Local $sString = "<pre>Match<br /></pre>" & @CRLF & _
"" & @CRLF & _
"<pre>Match<br />Match again<br /></pre>DONT MATCH<br />blablabla" & @CRLF & _
"<pre>" & @CRLF & _
"<br />" & @CRLF & _
"Hard mode : U should have been matched aswell</pre>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")