import re
regex = re.compile(r".*?<pre>.*\s?((<br\s*?\/?>\s?).*?){1,}<\/pre>", flags=re.MULTILINE)
test_str = ("<pre>Match<br /></pre>\n\n"
"<pre>Match<br />Match again<br /></pre>DONT MATCH<br />blablabla\n"
"<pre>\n"
"<br />\n"
"Hard mode : U should have been matched aswell</pre>\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")