const regex = /.*?<pre>.*\s?((<br\s*?\/?>\s?).*?){1,}<\/pre>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?<pre>.*\\s?((<br\\s*?\\\/?>\\s?).*?){1,}<\\\/pre>', 'gm')
const str = `<pre>Match<br /></pre>
<pre>Match<br />Match again<br /></pre>DONT MATCH<br />blablabla
<pre>
<br />
Hard mode : U should have been matched aswell</pre>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}