re = /.*?<pre>.*\s?((<br\s*?\/?>\s?).*?){1,}<\/pre>/m
str = '<pre>Match<br /></pre>
<pre>Match<br />Match again<br /></pre>DONT MATCH<br />blablabla
<pre>
<br />
Hard mode : U should have been matched aswell</pre>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end