$re = '/.*?<pre>.*\s?((<br\s*?\/?>\s?).*?){1,}<\/pre>/m';
$str = '<pre>Match<br /></pre>
<pre>Match<br />Match again<br /></pre>DONT MATCH<br />blablabla
<pre>
<br />
Hard mode : U should have been matched aswell</pre>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);