#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[A-Z][a-z]+\.(?:jpg|png|gif),){4,}$"
Local $sString = "Chrysanthemum.jpg,Desert.png,Hydrangeas.gif,Jellyfish.jpg,Koala.jpg,Lighthouse.png," & @CRLF & _
"Chrysanthemum.jpg,Desert.png,Hydrangeas.gif," & @CRLF & _
"Chrysanthemum.jpg," & @CRLF & _
"Chrysanthemum.jpg,Desert.png," & @CRLF & _
"Salvis.jpg,Sumeet.jpg,Jacob.png,Srlawr.png,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")