import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[A-Z][a-z]+\\.(?:jpg|png|gif),){4,}$";
final String string = "Chrysanthemum.jpg,Desert.png,Hydrangeas.gif,Jellyfish.jpg,Koala.jpg,Lighthouse.png,\n"
+ "Chrysanthemum.jpg,Desert.png,Hydrangeas.gif,\n"
+ "Chrysanthemum.jpg,\n"
+ "Chrysanthemum.jpg,Desert.png,\n"
+ "Salvis.jpg,Sumeet.jpg,Jacob.png,Srlawr.png,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}