using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[A-Z][a-z]+\.(?:jpg|png|gif),){4,}$";
string input = @"Chrysanthemum.jpg,Desert.png,Hydrangeas.gif,Jellyfish.jpg,Koala.jpg,Lighthouse.png,
Chrysanthemum.jpg,Desert.png,Hydrangeas.gif,
Chrysanthemum.jpg,
Chrysanthemum.jpg,Desert.png,
Salvis.jpg,Sumeet.jpg,Jacob.png,Srlawr.png,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}